Email notifications being delayed

Discussion in 'Communications' started by jcgoble3, Nov 22, 2013.

Moderators: JoinTheSchwarz, LAJ_FETT, Ramza
  1. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Just today I'm noticing that email notifications for watched topics and PMs are being delayed. A post was made at 11:34 AM (ET), but the email didn't arrive until 11:49 (despite the fact that it was timestamped 11:34). Another post was made at 8:27 AM, but the email for it didn't arrive until 10:05 (again, the timestamp on the email when I opened it matched the post). A conversation reply was sent at 8:25 AM; that email also arrived at 10:05 (and again the email's timestamp matched that of the reply). Any clue what could be going on here? I'm using Gmail, if it makes a difference.
  2. LAJ_FETT Tech Admin and Collecting/Games Mod

    Administrator
    Member Since:
    May 25, 2002
    star 9
    I don't use them so I haven't noticed. However, I have checked the server error log within Xenforo and there aren't any mail-related errors. Maybe it's a lag with your provider or there's a lag outside of Xenforo. Anyone else having issues?
  3. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    I doubt it's a Gmail issue, since Facebook email notifications are arriving when they should. I'll set a couple of watched topics on an IP.Board forum I also frequent and see what happens. If those arrive on time, then it's something on TFN's end.
  4. LAJ_FETT Tech Admin and Collecting/Games Mod

    Administrator
    Member Since:
    May 25, 2002
    star 9
    OK - you might tag Grimby if you think your email is receiving others OK.
  5. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Tagging @Grimby.

    Emails from the IP.Board forum arrived instantly, and the delays are still happening here. The typical delay is between 5 and 15 minutes, but there's no consistency, and as noted above, I had a pair of emails delayed by almost two hours this morning. I have noticed that if multiple emails are "en route" at once, they will all show up in my inbox at once. What I mean by that is, for example, if one thread is replied to at 5:13, and another is replied to at 5:17, and a convo reply is sent at 5:22:09, then when the first email lands in my inbox at, let's say, 5:22:14, the other two will show up at 5:22:14 as well.

    So it seems to me that there's something wrong on the mail server that holding back emails and then letting them go all at once. Possibly a connection issue of some kind, where it might lose connection for a few minutes and then send everything at once when it reestablishes the connection. I'm just taking a wild guess here.
  6. Grimby Technical Consultant

    Administrator
    Member Since:
    Apr 22, 2000
    star 7
    If that's the case, I would say it's most likely an issue with the email server and/or the way the system processes email alerts. And by "issue" I mean it's not something we can do anything about. This site probably processes and sends out hundreds if not thousands of emails a day. There's a limit to how many emails can be sent out at a time, so if you and 30 other people are set to get an email alert for a particular thread, some people might receive the email within 5 minutes, while others may take longer. I can't say for sure because I'm not familiar with the particular email server we use, but I do know that mail servers will often send out emails in batches rather than one at a time.

    A traditional email server works much differently than something like the Gmail app on your phone with those instant push notifications. The time it takes for our system to process the alert, send it to the email server for delivery, and make its way to your inbox can vary greatly depending on server load and how many emails are being processed. I'd say if your delay is only 5-15 minutes, everything is working correctly.
    Last edited by Grimby, Nov 22, 2013
  7. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Then how come until now I have always, ever since the beginning of the move when we first started up the temp boards, received the email within just a few seconds of the post being made? The system has done that without fail for over a year and a half, except for this problem today. Explain that to me.
  8. Rox Administrator Emeritus

    Member Since:
    Nov 24, 2000
    star 6
    more people are posting now and there is more pressure on the email server to keep up would be my guess
  9. harpua Chosen One

    Member Since:
    Mar 12, 2005
    star 8
    Do you really need to know the exact second that somebody posts in a certain thread? I think within 30 minutes (or even within a couple of hours) is pretty reasonable.
    Last edited by harpua, Nov 23, 2013
  10. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Sometimes discussions in my RPG's OOC discussion thread move very fast. After an hour I could be a whole page behind.
  11. Grimby Technical Consultant

    Administrator
    Member Since:
    Apr 22, 2000
    star 7
    If you want faster alerts and you have a smartphone, try downloading the Tapatalk app and turning on push notifications.
  12. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Tapatalk doesn't seem to allow me to turn on push notifications on a per-forum or per-alert-type basis. In order to turn on push notifications, it appears that I have to accept notifications for everything, including replies, likes, and tags, on all four of the forums that I use Tapatalk with (anywhere from 30 to 100 notifications per day), which would be a colossal waste of both my time and my extremely limited data (1 GB shared between my phone and my dad's phone). Not to mention that I actually have board notifications for replies to watched threads turned OFF so that I only get email notifications (because the board notifications are redundant, are not seen until after I have already viewed the post in question, and significantly clutter up my alert list at the top of the page), so without getting board notifications I don't know if I would even get push notifications for the one alert type I actually want.

    EDIT: OK, I figured out how to set it up. I will not consider this a solution, however, until I see how fast push notifications arrive, and how annoying it is when it goes off while I'm driving or sleeping.
    Last edited by jcgoble3, Nov 23, 2013
  13. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Well, that was a waste of effort. I am not receiving push notifications from Tapatalk AT ALL, despite multiple posts being made to one of my watched threads and having double- and triple-checked to make sure that they are indeed turned on.

    Got another solution, like, oh say, actually fixing the server issue?
  14. harpua Chosen One

    Member Since:
    Mar 12, 2005
    star 8
  15. Grimby Technical Consultant

    Administrator
    Member Since:
    Apr 22, 2000
    star 7
    In Tapatalk, each forum has its own notification settings and there is also an on/off setting in the main Tapatalk settings. So make sure you check both.

    And as I stated previously, the server "issue" is not something that can be "fixed". It's not a glitch. It has to do with server load and how many emails are being sent out.
  16. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Then figure out what is causing the excessive server load and find a way to relieve it. Because this has never been a problem until a couple days ago. Your claim would only make sense if it had been doing this more or less the entire time we've been on XenForo, and it hasn't.
  17. Grimby Technical Consultant

    Administrator
    Member Since:
    Apr 22, 2000
    star 7
    [IMG]

    When I say "server load" I mean the increased load on the server caused by increased site traffic and the increased number of users who use the notification system. Another factor may be the increased server load on rebelscum.com, as our emails are routed through their server before being sent out by (I believe) GoDaddy's email system.
  18. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    I still do not understand why all email notifications were instant for over a year up to last Thursday, and then abruptly on Friday they're suddenly being delayed for no discernible reason. What happened on Thursday night/Friday morning to cause a dramatic spike in site traffic that still hasn't died off? I don't know of any major Star Wars news that would have done this, and IIRC not even the traffic generated by the Disney purchase and sequel announcement last year caused this problem. This is what leads me to believe that there is a technical issue with the server that can be fixed. Your explanation is plausible when taken by itself, but when placed in context it makes no sense to me.
  19. Grimby Technical Consultant

    Administrator
    Member Since:
    Apr 22, 2000
    star 7
    I've already inquired about possible troubleshooting of the servers, but you should understand that if the cause is simply an increased number of users turning on and using the email notification feature (which is certainly possible), there really isn't anything that can be done.
  20. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    And I find it implausible that a whole bunch of users would suddenly decide to turn on email notifications all at one time. If the delays had gradually increased over the course of several weeks, then I could reasonably see increased usage of that feature as being a possibility, but that's not what happened. It abruptly went from perfect instant delivery Thursday night to delays on Friday morning.

    Also, the emails still contain the timestamp of the post in their headers, and when multiple emails are delayed, they all arrive simultaneously, which is why I suspect intermittent brief outages where emails are being generated properly and placed in the outbox immediately, but cannot actually be sent until the server reestablishes a connection.
  21. Grimby Technical Consultant

    Administrator
    Member Since:
    Apr 22, 2000
    star 7
    Well, that's exactly why I believe it's a matter of too many emails going out at once. When emails start backing up into a queue, they start getting batched and sent out in increments.
  22. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    That's interesting. However, it doesn't completely explain why sometimes a batch of emails that hits my inbox contains one that might be, say, 10 to 15, maybe 20 minutes old, and another one that is only seconds old. If the queue is that bad, I would expect the newest one to have to wait its own turn and thus be sent separately 10 to 15 minutes later, not jump the queue and tag along with the others. Either the system looks at the address of the top one in the queue and pulls everything else for that address (which I would think would be resource-intensive to the point of being impractical), or something else is going on.
  23. jcgoble3 Force Ghost

    Member Since:
    Nov 7, 2010
    star 4
    Hopefully I won't jinx it with this post, but email notifications are once again consistently coming in with no delay and have been all day today. Not sure what was wrong, but it seem to be fixed.
  24. harpua Chosen One

    Member Since:
    Mar 12, 2005
    star 8
    Well that's a relief.
  25. Sith-I-5 Force Ghost

    Member Since:
    Aug 14, 2002
    star 5
    I don't know about email notifications, but over Friday, I did notice the red numbered icons that materialise in the top right corner when there are updates in PM channels, were not appearing. Conversely to the above issue, it was email notifications in my Inbox that alerted me that there had been activity in the channel.

    Something is, or at least was, going on. Probably server load, as one said.

    EDIT: Just realised you guys are discussing a problem for Friday before last, while mine is the day before yesterday. Maybe something is now occurring on Fridays; a backup, or a server update or something.
    Last edited by Sith-I-5, Nov 30, 2013
Moderators: JoinTheSchwarz, LAJ_FETT, Ramza