main
side
curve

Lightsaber Glow/Color intensity help

Discussion in 'Fan Films, Fan Audio & SciFi 3D' started by StevenBills, Apr 4, 2018.

  1. StevenBills

    StevenBills Jedi Master star 4

    Registered:
    Jan 6, 2006
    Hey gang, it's certainly been a while. I'm roto'ing a short clip in AE, and am having problems compositing the glow and seeing the color correctly. The background can be considered "bright", but I've definitely seen sabers comped over brighter backgrounds without problem.

    I roto'd using Ryan Wieber's AE adjustment layer method, followed to the T, and this is as bright/colorful as a yellow saber that I can get:
    [​IMG]jimmy_saber1 by Steven Bills, on Flickr

    Here's the raw shot if anyone wants to take a whack at it:
    [​IMG]jimmy_saber1_raw by Steven Bills, on Flickr

    And here's a screenshot of my AE timeline for anyone who wants to dig deeper:
    [​IMG]AE timeline by Steven Bills, on Flickr

    Any advice on how to make the saber color pop more?

    SB
     
  2. TCF-1138

    TCF-1138 Porg of New Films & Fan Films star 5 Staff Member Manager

    Registered:
    Sep 20, 2002
    I've got to be honest, I haven't used the Wieber method in quite a while, but I can give it a go.

    I tried it out with Video CoPilot's Saber plug-in and got this result:

    [​IMG]

    It's not perfect, but it took me no more than a minute or two.
     
  3. StevenBills

    StevenBills Jedi Master star 4

    Registered:
    Jan 6, 2006
    I like that result a lot, except it seems like the glow tapers off towards the edges of the frame, like there's a "repeat edge pixels" checkbox turned off somewhere.

    Are you seeing that, or is it just me?
     
  4. TCF-1138

    TCF-1138 Porg of New Films & Fan Films star 5 Staff Member Manager

    Registered:
    Sep 20, 2002
    Yeah, you're right. Funny, I don't know how to fix that - there's no "repeat edge pixels" in Saber, and I've tried looking around for the solution, but so far no luck.

    I'll give the Wieber method a shot and see if I can come up with a solution to your original problem. :)
     
  5. TCF-1138

    TCF-1138 Porg of New Films & Fan Films star 5 Staff Member Manager

    Registered:
    Sep 20, 2002
    All right, having played around with it a bit, I think what your problem is is that you've set the Color Balance layer to Screen. If you just leave that as "normal", the color is more pronounced, while still not affecting the overall blending mode look.

    I made this, using your settings, but with a few tweaks:

    [​IMG]
    The Color Balance layer's blending mode was set to "Normal", and "Preserve Luminosity" to "Off". The top blur layer has an opacity of 25%, the one below of 50%, and the one below that at 75%. The ones below that are all set to 100% opacity.

    EDIT: Oh, I just realized I'd set the bottom Adjustment Layer to Screen as well, which is why the core is a bit hard. This is what happens when I set it to Normal:

    [​IMG]
     
    Last edited: Apr 5, 2018
  6. StevenBills

    StevenBills Jedi Master star 4

    Registered:
    Jan 6, 2006
    Okay, thank you so much @TCF-1138! I had already tried changing the blending mode of the color balance adjustment layer, but to no avail. So this morning I just deleted all of my glow layers and re-did them, and this is the result:

    [​IMG]jimmy_saber1_fixed by Steven Bills, on Flickr

    I honestly have no idea why it wasn't working before. The blending modes are the exact same as before, same blur amounts, opacities, etc...

    Thanks for your help!

    SB
     
    TCF-1138 likes this.