Mod Squad Update for the Week of 9/22/10 (Site Attack Epilogue)

Discussion in 'Communications' started by Katya Jade, Sep 23, 2010.

Thread Status:
Not open for further replies.
Moderators: JoinTheSchwarz, LAJ_FETT, Ramza
  1. Katya Jade Administrator Emeritus

    Member Since:
    Jan 19, 2002
    star 7
    Mod Squad Update for the Week of September 22, 2010

    - At this time, Google has flagged boards.theforce.net as a known attack site. Please be aware that we are currently working with IGN to find the problem and fix the issue. Until further notice, please take whatever precautions are necessary to keep yourself safe. This includes logging off the boards and refraining from posting or sending private messages.

    - Arena mods are still kicking around (har, har) game ideas.

    - The JC test boards are currently down and Phillip is looking into a cause.

    - Since Lost is over, problem users were sent to an island where we can observe them.


    Around the Boards:

    - JCC - Are You Good At Something? game is getting started so sign up if you have a talent you can submit!

    - Amphitheatre - Shelf of Shame are doing signups now.
  2. Ludo_Kressh Jedi Grand Master

    Member Since:
    Jun 30, 2005
    star 5
    What happened, I clicked on the two links in the message and they really didn't say much...were we hacked or something?[face_worried]
  3. Katana_Geldar Force Ghost

    Member Since:
    Mar 3, 2003
    star 8
    I was attacked, was scary.
  4. Grimby Technical Consultant

    Administrator
    Member Since:
    Apr 22, 2000
    star 7
    We weren't hacked as far as I can tell. Nothing on the image server looks out of place and I went through all the script files line by line and didn't see any altered code. IGN told me they scanned the database and couldn't find any trace of the malicious code.

    So what we know is that a few people reported attacks as recently as 1AM board time yesterday morning. Before that, a few other people had reported similar problems (see this thread from last week).

    Yesterday, Google also encountered the malicious code and flagged Boards.TheForce.net as an attack site, claiming that malicious code hosted on another site was being executed by our servers. From that point on, most people visiting the site saw warning messages pop up on their browsers warning them of the danger.

    At this time, we still don't know how this happened, but the important thing is that it's not happening anymore. We will continue to investigate the situation and attempt to locate the cause.
  5. Jada Chapter Rep Charlotte, NC

    Chapter Rep
    Member Since:
    Apr 20, 2006
    star 6
    This was worse than Wisegate! Except I didn't get banned. :p
  6. Ludo_Kressh Jedi Grand Master

    Member Since:
    Jun 30, 2005
    star 5
    Weird, because I posted on the boards during the period this was going on and I never got any warning messages. I use Norton anti-virus software ans use IE as my brower(not sure what version, I think it's the latest one.) I guess I was lucky, but it was scary to see that huge message plastered up on the banner.[face_worried]
  7. LAJ_FETT Tech Admin and Collecting/Games Mod

    Administrator
    Member Since:
    May 25, 2002
    star 9
    I use an older version of Norton Internet Security and it flagged the 'human-whatever' site right away. However I ran scans and nothing popped up as being a virus on my machine.
  8. ardavenport Force Ghost

    Member Since:
    Dec 16, 2004
    star 4
    I got a security warning from Firefox, so I stayed away until the warning cleared. Was the problem related to the forum move?
  9. LAJ_FETT Tech Admin and Collecting/Games Mod

    Administrator
    Member Since:
    May 25, 2002
    star 9
Moderators: JoinTheSchwarz, LAJ_FETT, Ramza
Thread Status:
Not open for further replies.