Question regarding motion blurs with alpha channels

Discussion in 'Scifi 3D Forum' started by darthdastoli, Aug 2, 2006.

Thread Status:
Not open for further replies.
  1. darthdastoli Force Ghost

    Member Since:
    Aug 4, 2000
    star 3
    I have been working in 3dsmax for six years now, so I feel like an idiot asking this question now. But I am a compositor primarily, so go easy on me.

    Anyway, my question is regarding "matte lines" when I render objects with motion blurs with alpha channels. Example: I render a blue sphere moving with a big motion blur across the screen. The environment is black. I render it with an Alpha pass. Now when I go into After Effects and use the alpha pass as a luma matte for the sphere, and lets say I want to put it on a redish background, there are black matte lines that appear.

    It makes sense of course that this happens. The blue sphere with a motion blur rendered against black will show a blue to black gradient at the edges. And the alpha will reveal whatever you see in the main pass of the sphere.

    What I have been doing for the past many years, is render the object against the bakground that it appears against in the final shot. But this is dumb. I always add so many other layers to the bg during compositing, so it ends up not being the same as whatever my 3d object was rendred out on.

    So my big question: How do people really do this? How do the pros do it? They obviously don't render it out against what the final background of the shot will be?
  2. darthviper107 Force Ghost

    Member Since:
    Jun 26, 2003
    star 4
    Well, technically it shouldn't make any matte lines at all, for instance, if you were to make an object and render it out along with an alpha pass and motion blur and then bring it back into 3ds Max, map it on a plane with the rendering as a diffuse map and the alpha as opacity, you won't get any matte lines. What I'm guessing is that the alpha maps are just not quite working correctly in After Effects, it may not really be made to use the alpha maps in that way.
  3. darthdastoli Force Ghost

    Member Since:
    Aug 4, 2000
    star 3
    No, going into 3dsmax and putting it on a plane with an opacity map yields the same result as doing it in After Effects. Here I've posted some images:

    [image=http://plpfilms.com/dastoli/1.jpg]blue sphere

    [image=http://plpfilms.com/dastoli/2.jpg]with alpha pass

    [image=http://plpfilms.com/dastoli/3.jpg]composited on red bg (notice black edges around it, and that's not caused by lighting)
  4. darthviper107 Force Ghost

    Member Since:
    Jun 26, 2003
    star 4
    Now do a rendering with the blue sphere against a red background like the one you want to comp it into, it is possible the blur is kind of dark because your sphere has no specific lighting and the edges are dark anyway.
  5. darthdastoli Force Ghost

    Member Since:
    Aug 4, 2000
    star 3
    The black edges are not caused by the default lighting, this problem occurs even with self illuminated objects. And I know that if I render against red it would be fine, but thats the point, I want to know how this is done without rendering against the final background of the shot, specifically when I've got big composited backgrounds that are built up after the 3d is already rendered.
  6. JinxKatarn Jedi Knight

    Member Since:
    Jan 8, 2001
    star 1
    What version of motion blur are you using? Image blur seems to be the most common so I'm going to guess it's that, which is likely where the problem is...object blur will too.

    I'd try using either camera-based blur (with around 15 samples) or using Mental Ray's blur if the system can handle that (it's a big strain).

    Image blur is a post-render effect applied so it may not do as accurate of a job representing the motion blur in the alpha channel, where as the camera-based blur is a multi-pass effect with the actual image just rendered however many times you specify (15 is decent) so that might give a much more accurate alpha. You'll see a much, much larger increase in your rendering time but it'll be more accurate both in image and alpha.

    MR's of course going to be the most realistic blur, but it is a beast to render even after 3.4's change to speed that up.

    Only other things I can recommend...get whatever you need done to the background of the composite & slap it in as a background, then render on top of it and then kick it back over to AE for final touches...OR...try layering either the exact same animation on top of it in AE, gaussian blur and then change to blending mode to screen/overlay/whichever. You'll get a sort of color-bleed/bloom effect off of that but it'll help with realism and soften edges. Putting a few spec map passes on top could help too, but that really depends on lighting.

    Hope something in this rant helps.

  7. darthdastoli Force Ghost

    Member Since:
    Aug 4, 2000
    star 3
    Well, I'm using version 5 so there's no mental ray built in. I was using an image motion blur, and I also tried an object motion blur with the same result.

    So basically there's no way other than to render on the background. I still can't imagine that the pros do it this way though.
  8. darthviper107 Force Ghost

    Member Since:
    Jun 26, 2003
    star 4
    Well, I've tested it out myself and it seems there's only a minor difference, the blur is slightly darker when it's comped in compared to rendering it directly over the background, but not like matte lines.


    but here is an interesting Vray tutorial that has some talks about comping animations into other animations with 3ds Max

    Vray Animation Tutorial
  9. Darth_Steven Jedi Master

    Member Since:
    Jul 14, 2002
    star 2
    Not absolutely sure on this one someone may say I'm totally wrong, but if you render off a tga sequence and set your "pre-multiply alpha" setting to unchecked it will use the purity of the colour of the ball and not take any of the background. With Pre-Multiply Alpha checked on the object (or ball in this case) will pick up the background colour in it's blur wake. Another way around it is to render off a PNG sequence as well....it isolates the objects from the background when it renders. Hope that helps....good luck.

    Later
    Steve
Thread Status:
Not open for further replies.